nixos-config/docker/kuma.nix

24 lines
452 B
Nix

{ config, pkgs, ... }:
let
host = "kuma.atlanticaweb.fr";
in
{
virtualisation = {
podman = {
enable = true;
dockerCompat = true;
};
oci-containers = {
backend = "podman";
containers.uptime-kuma = {
image = "louislam/uptime-kuma";
autoStart = true;
ports = [ "5001:3001" ]; #server locahost : docker localhost
volumes = [
"/srv/docker/uptime-kuma:/app/data"
];
};
};
};
}