36 lines
870 B
Nix
36 lines
870 B
Nix
{ config, pkgs, ... }:
|
|
{
|
|
programs.git = {
|
|
enable = true;
|
|
userEmail = "lucazeau.alexandre@gmail.com";
|
|
userName = "Alexandre LUCAZEAU";
|
|
aliases = {
|
|
ignore = "!gi() { curl -sL https://www.toptal.com/developers/gitignore/api/$@ ;}; gi";
|
|
};
|
|
extraConfig = {
|
|
"color" = {
|
|
"ui" = true;
|
|
};
|
|
"init" = {
|
|
defaultBranch = "main";
|
|
};
|
|
"color \"diff-highlight\"" = {
|
|
oldNormal = "red bold";
|
|
oldHighlight = "red bold 52";
|
|
newNormal = "green bold";
|
|
newHighlight = "green bold 22";
|
|
};
|
|
"color \"diff\"" = {
|
|
meta = 11;
|
|
frag = "magenta bold";
|
|
commit = "yellow bold";
|
|
old = "red bold";
|
|
new = "green bold";
|
|
whitespace = "red reverse";
|
|
};
|
|
};
|
|
#signing.key = "GPG-KEY-ID";
|
|
#signing.signByDefault = true;
|
|
};
|
|
}
|