nixos-config/hosts/web/hardware-configuration.nix

9 lines
279 B
Nix

{ modulesPath, ... }:
{
imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
boot.loader.grub.device = "/dev/sda";
boot.initrd.kernelModules = [ "nvme" ];
fileSystems."/" = { device = "/dev/sda2"; fsType = "ext4"; };
swapDevices = [ { device = "/dev/sda3"; } ];
}