nixos-config/modules/transmission.nix

16 lines
314 B
Nix

{ config, pkgs, lib, ... }:
{
services.transmission = {
enable = true;
openFirewall = true;
openRPCPort = true;
settings = {
rpc-bind-address = "0.0.0.0";
rpc-whitelist = "192.168.10.*";
rpc-whitelist-enable = true;
};
};
#networking.firewall.allowedTCPPorts = [ 9091 ];
}